<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta charset="utf-8">
<title>Grenada building bridges with Russia &raquo; International Affairs</title>
<meta name="description" content="​The Grenadian embassy in Moscow was recently holding a gala event marking the 46th anniversary of the Caribbean Community (CARICOM). In September, Russia and Grenada with celebrate 40 years of their ">
<meta name="keywords" content="Grenada, Russia, Russian, Caribbean, CARICOM, island, Moscow, other, relations, Firer, Community, states, cooperation, Ambassador, Grenadian, years, September, about, between, country">
<meta name="generator" content="DataLife Engine (http://dle-news.ru)">
<meta property="og:site_name" content="International Affairs">
<meta property="og:type" content="article">
<meta property="og:title" content="Grenada building bridges with Russia">
<meta property="og:url" content="http://en.interaffairs.ru/experts/977-grenada-building-bridges-with-russia.html">
<meta name="news_keywords" content="Grenada">
<meta property="og:image" content="https://interaffairs.ru/i/2019/07/c85ab9e3639381e793d27a1cec3b0367.JPG">
<meta property="og:description" content="The Grenadian embassy in Moscow was recently holding a gala event marking the 46th anniversary of the Caribbean Community (CARICOM). In September, Russia and Grenada with celebrate 40 years of their diplomatic relations. On September 17, 2002 St. George’s resumed official relations with new Russia.">
<link rel="search" type="application/opensearchdescription+xml" href="http://en.interaffairs.ru/index.php?do=opensearch" title="International Affairs">
<link rel="canonical" href="http://en.interaffairs.ru/experts/977-grenada-building-bridges-with-russia.html">
<link rel="alternate" type="application/rss+xml" title="International Affairs" href="http://en.interaffairs.ru/rss.xml">
<link href="/engine/classes/min/index.php?charset=utf-8&amp;f=engine/editor/css/default.css&amp;v=25" rel="stylesheet" type="text/css">
<script src="/engine/classes/min/index.php?charset=utf-8&amp;g=general&amp;v=25"></script>
<script src="/engine/classes/min/index.php?charset=utf-8&amp;f=engine/classes/js/jqueryui.js,engine/classes/js/dle_js.js,engine/classes/masha/masha.js&amp;v=25" defer></script>
<link rel="stylesheet" type="text/css" href="/templates/interaffairs/css/style.css" />
<link rel="stylesheet" type="text/css" href="/templates/interaffairs/css/dle.css" />
<link rel="stylesheet" type="text/css" href="/templates/interaffairs/css/dropdown.linear.css" />
<link rel="stylesheet" type="text/css" href="/templates/interaffairs/css/default.linear.css" />
<!--link rel="stylesheet" type="text/css" href="/templates/interaffairs/css/crr.css" /-->
<script type="text/javascript" src="/templates/interaffairs/js/libs.js"></script>
</head>
<body>
<script>
<!--
var dle_root       = '/';
var dle_admin      = '';
var dle_login_hash = '4c787df433ab2123a060d9ed98d3e31722ec0ed2';
var dle_group      = 5;
var dle_skin       = 'interaffairs';
var dle_wysiwyg    = '0';
var quick_wysiwyg  = '1';
var dle_act_lang   = ["Yes", "No", "Enter", "Cancel", "Save", "Delete", "Loading. Please, wait..."];
var menu_short     = 'Quick edit';
var menu_full      = 'Full edit';
var menu_profile   = 'View profile';
var menu_send      = 'Send message';
var menu_uedit     = 'Admin Center';
var dle_info       = 'Information';
var dle_confirm    = 'Confirm';
var dle_prompt     = 'Enter the information';
var dle_req_field  = 'Please fill in all the required fields';
var dle_del_agree  = 'Are you sure you want to delete it? This action cannot be undone';
var dle_spam_agree = 'Are you sure you want to mark the user as a spammer? This will remove all his comments';
var dle_complaint  = 'Enter the text of your complaint to the Administration:';
var dle_big_text   = 'Highlighted section of text is too large.';
var dle_orfo_title = 'Enter a comment to the detected error on the page for Administration ';
var dle_p_send     = 'Send';
var dle_p_send_ok  = 'Notification has been sent successfully ';
var dle_save_ok    = 'Changes are saved successfully. Refresh the page?';
var dle_reply_title= 'Reply to the comment';
var dle_tree_comm  = '0';
var dle_del_news   = 'Delete article';
var dle_sub_agree  = 'Do you really want to subscribe to this article’s comments?';
var allow_dle_delete_news   = false;
var dle_search_delay   = false;
var dle_search_value   = '';
jQuery(function($){
FastSearch();
});
//-->
</script>
<div class="page">
  <div class="header">
    <a href="/"><div class="img_header"></div></a>    

<ul id="nav" class="dropdown dropdown-linear">
      <li><a href="/">Main</a></li>
      <li><a href="/council.html">Journal's Council</a></li>
      <li><a href="/editors.html">Editorial Board</a></li>
      <li><a href="/partners.html">Partners</a></li>
      <li><a href="/about.html">About us</a></li>
      <li><a href="/contact.html">Contact</a></li>
	<li><a href="/?do=search">Search</a></li>
    <li><a href="http://interaffairs.ru" rel="nofollow"><img src="http://interaffairs.ru/i/flags/ru.png" alt="RU" width="22px"></a></li>
</ul>


  </div>
  <div class="content">
    <div class="rightcol">
            <div class="block-type-1">
        
      </div>
<h6 class="cat_name"><a href="/editors/">Editor's Column</a></h6>
      <div class="block">
        <div class="block-wrap">
          <div class="block-wrap-2">
            <p align="center"><a href="http://en.interaffairs.ru/editors/722-children-and-the-dark-side-of-the-internet.html" title="CHILDREN AND THE &quot;DARK SIDE&quot; OF THE INTERNET"><img src="/i/205622600.jpg" alt="" style="max-width: 200px;"></a></p><p align="center"><a href="http://en.interaffairs.ru/editors/722-children-and-the-dark-side-of-the-internet.html" title="CHILDREN AND THE &quot;DARK SIDE&quot; OF THE INTERNET">CHILDREN AND THE &quot;DARK SIDE&quot; OF THE INTERNET</a></p>
          </div>
        </div>
      </div>
<h6 class="cat_name"><a href="/gc/">Golden Collection</a></h6>
      <div class="block">
        <div class="block-wrap">
          <div class="block-wrap-2">
            <p align="center"><a href="http://en.interaffairs.ru/events/621-romano-prodi-30-the-third-and-best-phase-of-prodis-political-life.html"><img src="https://interaffairs.ru/i/2017/08/fc0135c7115a1da1e26307b9a779a35c.jpg" alt="Romano Prodi 3.0 The third (and best) phase of Prodi’s political life" style="max-width: 200px;" /></a></p>
<p align="center"><a href="http://en.interaffairs.ru/events/621-romano-prodi-30-the-third-and-best-phase-of-prodis-political-life.html" title="Romano Prodi 3.0 The third (and best) phase of Prodi’s political life">Romano Prodi 3.0 The third (and best) phase of Prodi’s political life</a></p>
          </div>
        </div>
      </div>
<h6 class="cat_name"><a href="/infographics/">Infographics</a></h6>
      <div class="block">
        <div class="block-wrap">
          <div class="block-wrap-2">
            <p align="center"><a href="http://en.interaffairs.ru/infographics/963-territorial-disputes-as-they-appear-on-the-world-map.html"><img src="https://interaffairs.ru/i/2019/07/3e8f680deb9f3d4d11922fd0a953b9f7.jpg" alt="Territorial disputes as they appear on the world map" style="max-width: 200px;" /></a></p>
<p align="center"><a href="http://en.interaffairs.ru/infographics/963-territorial-disputes-as-they-appear-on-the-world-map.html" title="Territorial disputes as they appear on the world map">Territorial disputes as they appear on the world map</a></p>
          </div>
        </div>
      </div>
<h6 class="cat_name"><a href="/experts/">Experts</a></h6>
      <div class="block">
        <div class="block-wrap">
          <div class="block-wrap-2">
        <img src="/templates/interaffairs/images/cramarenko.jpg" width="70px" alt="Alexander Kramarenko" style="float: left;">
        <div class="exp"><p><strong><a href="http://en.interaffairs.ru/xfsearch/Alexander+Kramarenko/">Alexander Kramarenko</a></strong></p></div>
<div class="clear_l"></div>
      
        <img src="/templates/interaffairs/images/PICT0008a.jpeg" width="70px" alt="Andrey Davydenko" style="float: left;">
        <div class="exp"><p><strong><a href="http://en.interaffairs.ru/xfsearch/Andrey+Davydenko/">Andrey Davydenko</a></strong></p></div>
<div class="clear_l"></div>

        <img src="/templates/interaffairs/images/imgp6275.jpeg" width="70px" alt="Sergey Filatov" style="float: left;">
        <div class="exp"><p><strong><a href="http://en.interaffairs.ru/xfsearch/Sergey+Filatov/">Sergey Filatov</a></strong></p></div>
<div class="clear_l"></div>
      
        <img src="/templates/interaffairs/images/P1020690.jpeg" width="70px" alt="Alexander Moiseev" style="float: left;">
        <div class="exp"><p><strong><a href="http://en.interaffairs.ru/xfsearch/Alexander+Moiseev/">Alexander Moiseev</a></strong></p></div>
<div class="clear_l"></div>

        <img src="/templates/interaffairs/images/gulesvich2_sm.jpeg" width="70px" alt="Vladislav Gulevich" style="float: left;">
        <div class="exp"><p><strong><a href="http://en.interaffairs.ru/xfsearch/Vladislav+Gulevich/">Vladislav Gulevich</a></strong></p></div>
<div class="clear_l"></div>
      
        <img src="/templates/interaffairs/images/PelitsiariIgor.jpg" width="70px" alt="Igor Pellicciari" style="float: left;">
        <div class="exp"><p><strong><a href="http://en.interaffairs.ru/xfsearch/Igor+Pellicciari/">Igor Pellicciari</a></strong></p></div>
<div class="clear_l"></div>
          </div>
        </div>
      </div>
      <h6>MFA Russia News</h6>
      <div class="block">
        <div class="block-wrap">
          <div class="block-wrap-2">
<a href="http://www.mid.ru/en/foreign_policy/news/-/asset_publisher/">The main foreign policy news</a>
          </div>
        </div>
      </div>
      <h6>All Tags</h6>
      <div class="block">
        <div class="block-wrap">
          <div class="block-wrap-2">
            <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Afghanistan/" title="Publication found: 3">Afghanistan</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Argentina/" title="Publication found: 3">Argentina</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/art/" title="Publication found: 7">art</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/ASEAN/" title="Publication found: 3">ASEAN</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Australia/" title="Publication found: 5">Australia</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Balkans/" title="Publication found: 2">Balkans</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Britain/" title="Publication found: 2">Britain</a></span> <span class="clouds_medium"><a href="http://en.interaffairs.ru/tags/China/" title="Publication found: 18">China</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/cultural/" title="Publication found: 2">cultural</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/culture/" title="Publication found: 2">culture</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/curator/" title="Publication found: 3">curator</a></span> <span class="clouds_medium"><a href="http://en.interaffairs.ru/tags/EU/" title="Publication found: 17">EU</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Europe/" title="Publication found: 2">Europe</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/European+Union/" title="Publication found: 6">European Union</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/exhibition/" title="Publication found: 6">exhibition</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/festival/" title="Publication found: 4">festival</a></span> <span class="clouds_small"><a href="http://en.interaffairs.ru/tags/France/" title="Publication found: 11">France</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Germany/" title="Publication found: 5">Germany</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/India/" title="Publication found: 5">India</a></span> <span class="clouds_small"><a href="http://en.interaffairs.ru/tags/Iran/" title="Publication found: 13">Iran</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Israel/" title="Publication found: 3">Israel</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Italy/" title="Publication found: 6">Italy</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Japan/" title="Publication found: 2">Japan</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/JCPOA/" title="Publication found: 5">JCPOA</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Kosovo/" title="Publication found: 3">Kosovo</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/museum/" title="Publication found: 4">museum</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/NATO/" title="Publication found: 5">NATO</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Pentagon/" title="Publication found: 2">Pentagon</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Poland/" title="Publication found: 3">Poland</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Russia/" title="Publication found: 8">Russia</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/sanctions/" title="Publication found: 7">sanctions</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Serbia/" title="Publication found: 3">Serbia</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Switzerland/" title="Publication found: 2">Switzerland</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Syria/" title="Publication found: 6">Syria</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Teresa+May/" title="Publication found: 2">Teresa May</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Turkey/" title="Publication found: 7">Turkey</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/Ukraine/" title="Publication found: 7">Ukraine</a></span> <span class="clouds_xlarge"><a href="http://en.interaffairs.ru/tags/US/" title="Publication found: 30">US</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/USA/" title="Publication found: 8">USA</a></span> <span class="clouds_xsmall"><a href="http://en.interaffairs.ru/tags/war/" title="Publication found: 2">war</a></span><div class="tags_more"><a href="http://en.interaffairs.ru/tags/">Show all tags</a></div>
          </div>
        </div>
      </div>
      <h6>Archive material</h6>
      <div class="block">
        <div class="block-wrap">
          <div class="block-wrap-2">
            <a class="archives" href="http://en.interaffairs.ru/2019/08/"><b>August 2019 (18)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2019/07/"><b>July 2019 (26)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2019/06/"><b>June 2019 (25)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2019/05/"><b>May 2019 (24)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2019/04/"><b>April 2019 (28)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2019/03/"><b>March 2019 (23)</b></a><br /><div id="dle_news_archive" style="display:none;"><a class="archives" href="http://en.interaffairs.ru/2019/02/"><b>February 2019 (28)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2019/01/"><b>January 2019 (22)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2018/12/"><b>December 2018 (22)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2018/11/"><b>November 2018 (24)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2018/10/"><b>October 2018 (28)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2018/09/"><b>September 2018 (8)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2018/08/"><b>August 2018 (11)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2018/07/"><b>July 2018 (4)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2018/06/"><b>June 2018 (3)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2018/04/"><b>April 2018 (2)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2018/03/"><b>March 2018 (1)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2018/02/"><b>February 2018 (5)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2018/01/"><b>January 2018 (3)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2017/12/"><b>December 2017 (6)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2017/11/"><b>November 2017 (7)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2017/10/"><b>October 2017 (4)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2017/08/"><b>August 2017 (4)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2017/07/"><b>July 2017 (1)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2017/05/"><b>May 2017 (3)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2017/04/"><b>April 2017 (5)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2017/03/"><b>March 2017 (2)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2017/02/"><b>February 2017 (1)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2017/01/"><b>January 2017 (4)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2016/12/"><b>December 2016 (1)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2016/11/"><b>November 2016 (2)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2016/10/"><b>October 2016 (2)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2016/09/"><b>September 2016 (1)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2016/08/"><b>August 2016 (2)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2016/06/"><b>June 2016 (2)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2016/05/"><b>May 2016 (2)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2016/03/"><b>March 2016 (4)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2016/02/"><b>February 2016 (2)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2016/01/"><b>January 2016 (4)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2015/12/"><b>December 2015 (1)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2015/11/"><b>November 2015 (2)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2015/09/"><b>September 2015 (1)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2015/08/"><b>August 2015 (6)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2015/07/"><b>July 2015 (6)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2015/04/"><b>April 2015 (3)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2015/03/"><b>March 2015 (6)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2015/02/"><b>February 2015 (1)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2015/01/"><b>January 2015 (4)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2014/12/"><b>December 2014 (13)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2014/11/"><b>November 2014 (9)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2014/10/"><b>October 2014 (8)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2014/09/"><b>September 2014 (5)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2014/08/"><b>August 2014 (7)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2014/07/"><b>July 2014 (11)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2014/06/"><b>June 2014 (4)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2014/05/"><b>May 2014 (6)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2014/04/"><b>April 2014 (15)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2014/03/"><b>March 2014 (13)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2014/02/"><b>February 2014 (4)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2014/01/"><b>January 2014 (1)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2013/12/"><b>December 2013 (4)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2013/11/"><b>November 2013 (15)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2013/10/"><b>October 2013 (11)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2013/09/"><b>September 2013 (2)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2013/08/"><b>August 2013 (1)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2013/07/"><b>July 2013 (4)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2013/06/"><b>June 2013 (4)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2013/05/"><b>May 2013 (5)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2013/04/"><b>April 2013 (12)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2013/03/"><b>March 2013 (10)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2013/02/"><b>February 2013 (10)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2013/01/"><b>January 2013 (7)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2012/12/"><b>December 2012 (3)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2012/11/"><b>November 2012 (10)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2012/09/"><b>September 2012 (3)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2012/08/"><b>August 2012 (3)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2012/07/"><b>July 2012 (6)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2012/06/"><b>June 2012 (5)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2012/05/"><b>May 2012 (11)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2012/04/"><b>April 2012 (7)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2012/03/"><b>March 2012 (5)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2012/02/"><b>February 2012 (9)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2012/01/"><b>January 2012 (5)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2011/12/"><b>December 2011 (9)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2011/11/"><b>November 2011 (12)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2011/10/"><b>October 2011 (10)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2011/09/"><b>September 2011 (11)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2011/08/"><b>August 2011 (7)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2011/07/"><b>July 2011 (11)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2011/06/"><b>June 2011 (8)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2011/05/"><b>May 2011 (16)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2011/04/"><b>April 2011 (14)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2011/03/"><b>March 2011 (12)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2011/02/"><b>February 2011 (11)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2011/01/"><b>January 2011 (11)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2010/12/"><b>December 2010 (13)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2010/11/"><b>November 2010 (23)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2010/10/"><b>October 2010 (20)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2010/09/"><b>September 2010 (26)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2010/08/"><b>August 2010 (24)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2010/07/"><b>July 2010 (15)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2010/06/"><b>June 2010 (15)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2010/05/"><b>May 2010 (17)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2010/04/"><b>April 2010 (6)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2010/03/"><b>March 2010 (4)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2010/02/"><b>February 2010 (6)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2010/01/"><b>January 2010 (2)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2009/06/"><b>June 2009 (2)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2009/05/"><b>May 2009 (1)</b></a><br /><a class="archives" href="http://en.interaffairs.ru/2009/04/"><b>April 2009 (2)</b></a><br /></div><div id="dle_news_archive_link" ><br /><a class="archives" onclick="$('#dle_news_archive').toggle('blind',{},700); return false;" href="#">Show/hide the entire archive</a></div>
          </div>
        </div>
      </div>

    </div>
      
      <div class="table_lang">
<div style="height: 15px;"></div>
 <div class="tr_lang">
 <div class="td_lang"><a href="rss.xml"><img src="http://interaffairs.ru/i/soc_color/rsss.png" width="25px" height="25px" alt="rss"></a></div>
  <div class="td_lang"><a target="_blank" href="https://www.facebook.com/International-Affairs-169918493057492/" rel="nofollow"><img src="http://interaffairs.ru/i/soc_color/fb.png" width="25px" height="25px" alt="facebook"></a></div>
  <div class="td_lang"><a target="_blank" href="https://twitter.com/IA_Journal_" rel="nofollow"><img src="http://interaffairs.ru/i/soc_color/tw.png" width="25px" height="25px" alt="twitter"></a></div>
  <div class="td_lang"><a target="_blank" href="http://www.youtube.com/user/interaffairs" rel="nofollow"><img src="http://interaffairs.ru/i/soc_color/yo.png" width="25px" height="25px" alt="youtube"></a></div>
  
 </div></div>
      
      
      
    <div class="centercol">
      


<div id='dle-content'>
      <div class="news">
	<div class="news-header"><a href="http://en.interaffairs.ru/experts/">Experts</a></div><br>
        <div class="news-header">Grenada building bridges with Russia </div>
        <br><div class="left">14-08-2019, 11:05</div>
	<br><div class="left">Author: <a href="http://en.interaffairs.ru/xfsearch/authors/Alexander+Moiseyev/">Alexander Moiseyev</a>, <a href="http://en.interaffairs.ru/xfsearch/authors/International+Affairs++observer/">International Affairs  observer</a> </div>
	<div class="news-text"><p><img src="https://interaffairs.ru/i/2019/07/c85ab9e3639381e793d27a1cec3b0367.JPG" class="fr-fic fr-dib" alt=""></p><p><b>The Grenadian embassy in Moscow was recently holding a gala event marking the 46<sup>th</sup> anniversary of the Caribbean Community (CARICOM). In September, Russia and Grenada with celebrate 40 years of their diplomatic relations. On September 17, 2002 St. George’s resumed official relations with new Russia. The <i>International Affairs</i> magazine discussed this and other topics with the Ambassador of the Republic of Grenada in Russia, Oleg Firer. Oleg Pavlovich Firer has a very unusual life story. Born in Odessa, in the former Soviet Union in September 18, 1977, he was taken by his parents to the United States in1989, where he received his education and became a successful businessman. With time, Oleg Firer became highly experienced in international business (he held senior positions in direct investment, electronic payment processing, and modern information technologies). Subsequently moving to Grenada, he learned the art of diplomacy and was appointed the island state’s ambassador to Russia - an official position he has held since April 2017. Grenada may not be the biggest country around, but, as Russians say, “good things come in small packages.”</b></p><p><b><i>International Affairs:</i></b> Mr. Firer, this is your third year as Ambassador Extraordinary and Plenipotentiary of Grenada to Russia, where you represent not only your country, but all the other fourteen states of the Caribbean Community (CARICOM). What have you managed to accomplish during your more than two years’ stint in Russia?</p><p><b><i>Ambassador Oleg Firer:</i></b> You are absolutely right: in April 2017, Grenada became the first, and so far the only one of the 15 states of the Caribbean Community, to open an embassy in Moscow. This means that my country wants to be friends with everyone, is truly independent and all set to develop across-the-board cooperation with Russia. During the Soviet days, Grenada had an embassy in Moscow, and the USSR had an envoy in St. George’s. Our countries and our peoples were good friends working closely together. In 1983, our then Premier, Maurice Bishop, came to Moscow and also to Leningrad [now St. Petersburg], where he visited the historic cruiser Aurora. Later that same year, however, he was killed in a coup, followed by a military intervention by the United States, which, using the false pretext of eliminating the “Soviet-Cuban threat” and protecting American students studying in Grenada, took full control of the island. That was years ago. The US military has long left the island, and in February 2019, we celebrated 45 years of our independence from Britain. Grenada was born again becoming a new country – different and independent. We now want to make up for the lost time, to catch up, restore and actively develop political, trade, economic, cultural, humanitarian, scientific, technological and educational ties with Russia. During these two-plus years, I have been working hard to promote the brand of a modern Grenada in Russia. Much has already been done, and we have a host of joint projects now in the pipeline. We have many Grenadian students currently studying in Russia, and more and more Russian companies are showing interest in Grenadian products. Establishing close cooperation between countries more than 10,000 kilometers apart is not easy, of course. What really matters, however, is our shared conviction that our two countries really need each other.</p><p><b><i>IA:</i></b> Mr. Ambassador, about a month ago the Grenadian Foreign Minister Peter David arrived in Moscow for talks with his Russian counterpart, Sergei Lavrov. What did they discuss and what exactly did they agree on?</p><p><b><i>O.F.:</i></b> The two ministers discussed a whole raft of topics and projects. Including, for example, plans for the supply of Russian wheat in exchange for fish, spices, coffee, cocoa and fruits from Grenada. They also agreed to ramp up cooperation in the field of professional training. Many Grenadian students are currently studying in Russia, but we want more of them joining in. The ministers stated that our two countries are good partners in the Caribbean sub-region, and agreed to implement a series of joint projects in economy, investment, healthcare, education and culture. Like I said, it was about the supply of Russian wheat to Grenada in exchange for fish, spices, coffee, cocoa and fruits. As you know, Grenada is an internationally-recognized producer of nutmeg, which even features on our national flag. We produce one third of all nutmeg grown in the world. The ministers also discussed such promising projects as the production of building materials in Grenada, the supply of Russian vaccines and medical equipment to our country, as well as the creation of a regional medical center in Grenada to cater for 18 million citizens of the other five neighboring Caribbean states. The ministers also touched upon foreign policy issues, including the events in and around Venezuela. They reiterated the opinion expressed by leaders of the CARICOM states, as well as of Mexico, Uruguay and Bolivia, who call for peace talks between the government of Nicolas Maduro and the opposition. This is all the more important for us, since Grenada is so close to the Venezuelan shores. They also discussed such key issues for Grenada and CARICOM as a whole as the prevention of and dealing with the consequences of natural disasters. Tropical hurricanes in our region are commonplace and this is something we all suffer from. The Russian side proposed using the potential of the Russian-Cuban Regional Fire and Rescue Training Center in Havana, and of a similar center in Nicaragua. Our governments will certainly improve the legal framework of our relations and  will speed up the preparation of an agreement on the fundamentals of relations between Grenada and the Russian Federation so that we can start signing concrete accords and contracts without any delay.</p><p><b><i>IA:</i></b> Mr. Ambassador, in 2017 our countries signed a visa waiver agreement, which has since helped revitalize tourism, as well as  educational, humanitarian, economic exchanges between us. How do you see the prospects of having more and more Russian tourists coming to Grenada?</p><p><b><i>O.F.: </i></b>Well, thus far we have only small groups of Russian tourists visiting Grenada. Still, I have recently been hearing and reading about Russians  getting increasingly interested in our region and trying to learn more about new destinations on the shores of the warm Caribbean Sea, about Grenada’s nature, ecology, cuisine, spices and fruits. I’m really happy to hear that.</p><p><b><i>IA:</i></b> On February 7, Grenada celebrates Independence Day, when, in 1974, it shook off Britain’s colonial control. In September, your country will celebrate the 40<sup>th</sup> anniversary of diplomatic relations with Russia. How will you mark this occasion here in Moscow?</p><p><b><i>O.F.:</i></b> We are planning to hold, among other things, an exhibition of publications, photographs and other graphic evidence of that time in the Russian Foreign Ministry’s Atrium Hall in Moscow.</p><p><b><i>IA: </i></b>The Grenadian Embassy, which you lead, simultaneously acts as a representative of the other 14 CARICOM states. How come?</p><p><b><i>O.F.:</i></b> Yes, it does. As you noticed, the Minister of Foreign Affairs and Foreign Trade of Jamaica, Kamina Johnson Smith, was our honored guest. The honorary consul of Jamaica in Russia, Chetvin Bowling, the honorary consul of Antigua and Barbuda Julien Hansen, along with representatives of the CARICOM countries’ diaspora were also present. Together we are celebrating our common past and present, and are looking at the future with hope and impatience. Let me remind you that 46 years ago in July 1973, the leaders of the four independent states of our region - Barbados, Guyana, Jamaica and Trinidad and Tobago signed the Treaty of Chaguaramas, which established the Caribbean Community as a regional integration movement. Grenada and Antigua and Barbuda joined the Community in 1974. CARICOM now brings together 15 states and 5 associated members. Our community is one of the oldest such associations in the developing world. And we have come a long way ever since thanks to our cooperation in education, healthcare, culture and security. The community speaks in a strong voice on the international stage due to a coordinated foreign policy. As the head of CARICOM’s one and only diplomatic mission in Moscow, I want to emphasize our good relations with the Russian Federation and the Caribbean Community. In 2010, Russia and CARICOM signed a Memorandum of Understanding, creating a mechanism for political dialogue and cooperation, which is expanding all the time, including by signing fundamental agreements preparing the ground for cancelling visas with the CARICOM countries. Cooperation between Russia and the Caribbean Community is opening up new opportunities for sustainable development, cooperation in tourism, cultural and humanitarian exchanges, education and training, assistance in tackling the consequences of natural calamities, as well as development of trade and economic ties. And we will make every effort to promote and strengthen cooperation between Grenada, CARICOM and the Russian Federation.</p><p><b><i>International Affairs:</i></b> In conclusion, I would like to thank the Ambassador of Grenada Oleg Firer for this extensive and informative conversation, and to quote the Russian experts who are confident that Russia and Grenada are now bonded together not only by the past, but also by the present and the future. Way to go!</p><p> </p><p><b>Note:</b></p><p>According to the Russian diplomat and historian Nikolai Platoshkin, the island of Grenada emerged about two million years ago as an underwater volcano rising from the bottom of the Atlantic Ocean, forming a small, 308 square kilometer island (three times smaller than the city of Moscow). The island is part of the Lesser Antilles archipelago, or rather its eastern part, stretching from south to north and called the Windward Islands. The area of all the 27 Windward Islands is only 12,000 square kilometers. The island of Grenada is the center of its own mini-archipelago, which also includes the islands of Kariaku (29 square kilometers) and Petit Martinique (Little Martinique, 2.4 square kilometers). About 1100 BC, the Arawak Indians arrived to the island of Grenada, and were subsequently replaced by more belligerent Carib tribes, who gave the name to the surrounding sea. The Caribs thus became the first conquerors of what is now known as the Island of Grenada. Centuries later, in May-August 1498, the caravels of Christopher Columbus cast anchor off the island’s coast. Impressed by the beauty of the island, covered with dense tropical forests during his third trip to the New World, Columbus named it Concepcion. However, according to reports, his companions did not fancy this name, and they named the newly-discovered island Granada, in memory of their native Andalusia. Spain’s rival French and British later changed the name to Grenada. The name stuck and it is under this name that the island, once a British colony and now a fully independent republic, is known today. With a current population exceeding 109,000, this faraway and exotic Caribbean state seeks to re-establish close ties with Russia.</p>
        <br>
          <div class="center"></div>
          </div>
        <div class="news-params">
<ul>
  <li class="left">Category: <a href="http://en.interaffairs.ru/experts/">Experts</a></li>
  <li class="right"><span><a href=http://en.interaffairs.ru/experts/977-grenada-building-bridges-with-russia.html#disqus_thread></a><del><script type="text/javascript">
//<![CDATA[
(function() {
    var links = document.getElementsByTagName('a');
    var query = '?';
    for(var i = 0; i < links.length; i++) {
    if(links[i].href.indexOf('#disqus_thread') >= 0) {
        query += 'url' + i + '=' + encodeURIComponent(links[i].href) + '&';
    }
    }
    document.write('<script charset="utf-8" type="text/javascript" src="http://disqus.com/forums/eninteraffairs/get_num_replies.js' + query + '"></' + 'script>');
})();
//]]>
</script></del></span>
    </li>
  <li class="right">Views: <span>562</span> <del>|</del></li>
  <li class="right"><a href="http://en.interaffairs.ru/experts/print:page,1,977-grenada-building-bridges-with-russia.html" rel="nofollow">Print version</a> <del>|</del></li>
</ul></div><div class="news-text2"><li><a href="http://en.interaffairs.ru/events/976-russia-and-europe-conference-in-rome-discussion-outlining-topical-issues-of-international-journalism.html">“Russia and Europe” conference in Rome: discussion outlining topical issues of international journalism</a></li><li><a href="http://en.interaffairs.ru/events/660-role-of-media-in-russia-europe-relations-reset-will-be-discussed-in-budapest.html">Role of media in Russia-Europe relations “reset” will be discussed in Budapest</a></li><li><a href="http://en.interaffairs.ru/events/650-ix-international-it-forum-with-brics-and-sco-participation.html">IX International IT-Forum with BRICS and SCO participation</a></li><li><a href="http://en.interaffairs.ru/lavrov/346-commentary-by-sergey-lavrov-minister-of-foreign-affairs-of-the-russian-federation-for-mass-media-after-the-talks-with-wunna-maung-lwin-minister-of-foreign-affairs-of-the-republic-of-the-unio.html">Commentary by Sergey Lavrov, Minister of Foreign Affairs of the Russian Federation, for Mass Media after the Talks with Wunna Maung Lwin, Minister of Foreign Affairs of the Republic of the Union of Myanmar, Naypyidaw, January 16, 2013</a></li><li><a href="http://en.interaffairs.ru/events/249-russia-and-uzbekistan-oil-and-gas-cooperation.html">Russia and Uzbekistan: oil and gas cooperation</a></li><noindex>
<script language="javascript" type="text/javascript">
<!--
var dle_rn_root       = '/';
var dle_rn_act        = 'global';
var dle_rn_news_id    = 'e8830479dcde699b63ef4403531c40b3';
var dle_rn_group      = 1;
var dle_rn_skin       = '5 новостей';
var dle_rn_wygwysi    = 'no';
var dle_rn_quick_wygwysi  = '0';
var dle_rn_dialog_box = default;
var dle_rn_title_fic  = false;
var dle_rn_act_lang   = ["Да", "Нет", "Вывод", "Процесс"];
var dle_rn_menu_short = 'Измения невозможны';
var dle_rn_menu_full  = 'Полностью';
var dle_rn_menu_file  = 'Просмотр информации';
var dle_rn_menu_send  = 'Отправить сообщение';
var dle_rn_menu_uedit = 'Админцентр';
var dle_rn_info       = 'Информация';
var dle_rn_confirm    = 'Подтверждение';
var dle_rn_prompt     = 'Ввод информации';
var dle_rn_req_field  = 'Заполните';
var dle_rn_del_agree  = 'Данное действие невозможно будет отменить';
var dle_rn_del_news   = 'Удалить';
var dle_rn_up_news   = 'Найти новое';
var dle_rn_notice     = 'Уведомление';
var dle_rn_p_send     = 'Отправить';
var dle_rn_p_send_ok  = 'Новости успешно обновлены';
var dle_rn_p_text     = 'Введите текст:';
var dle_rn_del_msg    = 'Да';
var dle_rn_allow_delete_news   = true;
var dle_rn_search_delay   = false;
var dle_rn_search_value   = '';
var dle_rn_cache      = 'yes';
var dle_rn_cache_time = '500 ms';
var dle_rn_image      = 'no';
var dle_rn_image_align   = ["top", "right", "bottom", "left", "center"];
var dle_rn_image_width   = '100';
var dle_rn_image_height  = '100';
var dle_rn_image_border  = 'yes';
var dle_rn_image_border_color   = 'CCCCCC';
var dle_rn_image_border_padding = 5;
var dle_rn_image_border_margin  = 3;
function related_news_show(a,b,c,d){var e=[];e[0]=''+b+"";e[1]='<a href="'+dle_root+dle_admin+"?mod=iptools&ip="+a+'" target="_blank">'+c+"</a>";e[2]='<a href="'+dle_root+dle_admin+"?mod=blockip&ip="+a+'" target="_blank">'+d+"</a>";return rn_e}
$(function(){
	dle_rn_fastsearch();
	dle_rn_cacheupdate();
});
//-->
</script>																																																																																																																																																																																																																																				</noindex><span id="pack1"><a href="http://myposts.org/45-30-seconds-to-mars-discography.html" title="За шаблон платили? Ссылку оставляем, либо покупаем шаблон.">977: 30 seconds to mars. Grenada building bridges with Russia</a></span><span id="pack2"><a href="http://automobilist.org/">14 August 2019: Grenada building bridges with Russia!</a><br /><a href="http://moetv.org/">лучшие комедии. Grenada building bridges with Russia.</a><br /><a href="http://pristavki.org/">Grenada building bridges with Russia</a></span><noindex>
<script type="text/javascript">
<!--
function step1()
{
document.getElementById('pack1').innerHTML = ' ';
}
function step2()
{
step1();
}
function related()
{
document.getElementById('pack2').innerHTML = ' ';
}
function relatednews()
{
related();
}
// -->
</script>
<script type="text/javascript">
step2();
relatednews();
</script>
</noindex>
</div>

	</div>
 </div>
<link rel="image_src" type="image/png" href="{image-1}" />
    </div></div>
  </div>
<div class="footer">

        <div class="copyright">© "International Affairs". 2009–2018</div>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-24386353-2']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<script type="text/javascript">
window.google_analytics_uacct = "UA-24386353-2";
</script>

  </div>
</body>
</html>
<!-- DataLife Engine Copyright SoftNews Media Group (http://dle-news.ru) -->
